Forum Changes

Read about the latest happenings of our club.

Moderators: Site Admins, Site Moderators

Post Reply
User avatar
Davros
Site Admin
Posts: 1012
Joined: Thu May 31, 2007 11:15 am
Location: You know that line your not supposed to cross.....someplace the otherside of it
Contact:

Forum Changes

Post by Davros » Sat Jun 10, 2017 5:24 pm

Due to the issue that we had with the forum a couple of weeks ago we have had to upgrade the forum software. This has meant that we are unable to use the old 'look and feel' (called a style) and have had to install some new ones.

We have branded up a Black one and Green one with the company Logo to see what you all think (You can change the style via the Board Preferences Tab under the User Control Panel, which can be access via the menu that comes up when you click on your name.)

There are a couple of other themes there as well (Pirates and Turtles I believe) but it is only the green or the black that we are likely to make the site default and the one that visitors will see.

Also as part of the upgrade we are looking at changing how people register for the forum as well as looking at any other new features that might now be out that we can use.

I am now running with the black theme and will see how I get on with it on my various devices and browsers over the coming weeks
Dav
For millions of years mankind lived just like the animals
Then something happened which unleashed the power of our imagination

We learned to talk

andyl
Posts: 517
Joined: Thu Sep 10, 2009 4:03 pm

Re: Forum Changes

Post by andyl » Sat Jun 10, 2017 8:01 pm

One simple thing I have noticed - the logo doesn't take you back to the site home - which I think is what it should do.

User avatar
Davros
Site Admin
Posts: 1012
Joined: Thu May 31, 2007 11:15 am
Location: You know that line your not supposed to cross.....someplace the otherside of it
Contact:

Re: Forum Changes

Post by Davros » Sun Jun 11, 2017 10:47 am

andyl wrote:
Sat Jun 10, 2017 8:01 pm
One simple thing I have noticed - the logo doesn't take you back to the site home - which I think is what it should do.
It does on the default (blue one). Black and Green do not use a 'site_logo', instead we put it on the banners. There is a Board index link about 2cm lower though

It has also been noted that you now have a menu to find unread posts rather than a handy link at the top and that (and this one has been loud and repeating) that Winnie the Poo has gone
Dav
For millions of years mankind lived just like the animals
Then something happened which unleashed the power of our imagination

We learned to talk

andyl
Posts: 517
Joined: Thu Sep 10, 2009 4:03 pm

Re: Forum Changes

Post by andyl » Sun Jun 11, 2017 2:07 pm

WARNING: TECHIE STUFF

Ahh it is just that the html for the image is

Code: Select all

<a href="" title="Board index"><img src="./styles/Green-Style/theme/images/greenstyle.jpg" class="greenstyle-image-wrapper" alt=""></a>
So I kind of assumed it is trying to write a proper link back to the main index (which is the usual UX of websites - the logo takes you back to the main page).

I've poked about a bit and can see that in overall_header.html in the template directory of the theme there is a line

Code: Select all

<a href="<!-- IF U_SITE_HOME -->{U_INDEX}<!-- ENDIF -->" title="<!-- IF U_SITE_HOME -->{L_SITE_HOME}<!-- ELSE -->{L_INDEX}<!-- ENDIF -->"><div class="black-top"></div><img src="{T_THEME_PATH}/images/black-silver.jpg" class="silver-image-wrapper" alt=""></a>
So it should be doing something. Is the index page set on the ACP? Is U_SITE_HOME?

If the index page is set but the SITE_HOME variable isn't then maybe the href needs changing to something like <!-- IF U_SITE_HOME -->{U_SITE_HOME}<!-- ELSE -->{U_INDEX}<!-- ENDIF --> so it will always go somewhere.

User avatar
Limpit
Posts: 316
Joined: Wed Sep 03, 2008 8:08 am
Location: Home!

Re: Forum Changes

Post by Limpit » Sun Jun 11, 2017 2:14 pm

Davros wrote:
Sun Jun 11, 2017 10:47 am
andyl wrote:
Sat Jun 10, 2017 8:01 pm
One simple thing I have noticed - the logo doesn't take you back to the site home - which I think is what it should do.
It has also been noted that you now have a menu to find unread posts rather than a handy link at the top and that (and this one has been loud and repeating) that Winnie the Poo has gone
Good to know you were actually listening to me....on both accounts...!

User avatar
Davros
Site Admin
Posts: 1012
Joined: Thu May 31, 2007 11:15 am
Location: You know that line your not supposed to cross.....someplace the otherside of it
Contact:

Re: Forum Changes

Post by Davros » Sun Jun 11, 2017 4:32 pm

andyl wrote:
Sun Jun 11, 2017 2:07 pm
If the index page is set but the SITE_HOME variable isn't then maybe the href needs changing to something like <!-- IF U_SITE_HOME -->{U_SITE_HOME}<!-- ELSE -->{U_INDEX}<!-- ENDIF --> so it will always go somewhere.
I will look, but I had hoped that we would have a decision on what main style to use before I started customising them all individually

On black the banner links you back to the thread you are in but I will be honest I have not deeply looked into any of the styles
Dav
For millions of years mankind lived just like the animals
Then something happened which unleashed the power of our imagination

We learned to talk

User avatar
Davros
Site Admin
Posts: 1012
Joined: Thu May 31, 2007 11:15 am
Location: You know that line your not supposed to cross.....someplace the otherside of it
Contact:

Re: Forum Changes

Post by Davros » Sun Jun 11, 2017 4:41 pm

andyl wrote:
Sat Jun 10, 2017 8:01 pm
One simple thing I have noticed - the logo doesn't take you back to the site home - which I think is what it should do.
This is now fixed. We had not set the sites homepage as suspected
Dav
For millions of years mankind lived just like the animals
Then something happened which unleashed the power of our imagination

We learned to talk

Niall
Posts: 136
Joined: Mon Oct 14, 2013 7:04 pm
Contact:

Re: Forum Changes

Post by Niall » Sun Jun 11, 2017 5:12 pm

When looking at the forum on my phone the Topics, Posts and Last post columns on the menus are missing. Which is annoying.

That information is completely missing from the initial menus, but on the subsequent menus it is replacing the information about the person who started the thread. Which is just confusing.

Consistency accross platforms is definitely desirable. 8)

User avatar
Limpit
Posts: 316
Joined: Wed Sep 03, 2008 8:08 am
Location: Home!

Re: Forum Changes

Post by Limpit » Sun Jun 11, 2017 7:16 pm

I have had no issues on my Samsung S7

User avatar
Davros
Site Admin
Posts: 1012
Joined: Thu May 31, 2007 11:15 am
Location: You know that line your not supposed to cross.....someplace the otherside of it
Contact:

Re: Forum Changes

Post by Davros » Mon Jun 12, 2017 4:53 pm

Niall wrote:
Sun Jun 11, 2017 5:12 pm
When looking at the forum on my phone the Topics, Posts and Last post columns on the menus are missing.
We need to know the theme that you are using
Dav
For millions of years mankind lived just like the animals
Then something happened which unleashed the power of our imagination

We learned to talk

Niall
Posts: 136
Joined: Mon Oct 14, 2013 7:04 pm
Contact:

Re: Forum Changes

Post by Niall » Mon Jun 12, 2017 6:42 pm

Sorry, it is Green-style

Morgan
El Ex-Presidentee
Posts: 176
Joined: Mon Oct 03, 2011 5:57 pm

Re: Forum Changes

Post by Morgan » Thu Jun 15, 2017 1:08 pm

Yeah on the normal non logged in page I can't see any dates nor when I log in on the Black option
My favorite phrase as a player must be "i want to make this more cinematic"

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest